An activation / deactivation always applies to the signal statement before, so why don't we change the syntax to clearly indicate that.
So instead of
why don't we do something like
In my opinion this would make the real meaning of an activation a lot clearer.
How do you think about that?